Autor Beitrag
mats
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starontopic star
Beiträge: 45



BeitragVerfasst: Di 14.08.18 09:31 
Hallo,

habe vor kurzem von Sebastian Jänicke einen geposteten Code zum versenden von eMail via Indy und Delphi (Community Edition) ausprobiert. Er wird ohne Probleme compiliert, aber bei der Ausführung bekomme ich eine Exeption (Bild). Ich habe die dll's von Fulgan.com heruntergeladen (openssl-1.0.2o-i386-win32.zip), und sie befinden sich im selben Verzeichnis, doch der Fehler bleibt. Brauche ich vielleicht doch nicht die 'neueste' Version?

mats
Einloggen, um Attachments anzusehen!
jaenicke
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starofftopic star
Beiträge: 18694
Erhaltene Danke: 1620

W10 x64 (Chrome, IE11)
Delphi 10.2 Ent, Oxygene, C# (VS 2015), JS/HTML, Java (NB), PHP, Lazarus
BeitragVerfasst: Di 14.08.18 11:13 
Der in dem Thread gepostete Code ist alles was in dem Projekt drin ist und ich habe auch die DLLs aus dem genannten Zip-Archiv verwendet. Keine Ahnung was da passiert.

Am besten schaust du einmal mit dem Process Monitor wo die DLLs gesucht werden usw.
mats Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starontopic star
Beiträge: 45



BeitragVerfasst: Di 14.08.18 16:07 
Hallo,

mit dem ProzessMonitor bin ich nicht so recht klargekommen, habe aber im Netz eine Seite mit einem Tool gefunden: slproweb.com/products/Win32OpenSSL.html. Danach gab es keine Probleme mehr.

Alles klar

m.