Autor Beitrag
daywalker0086
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starontopic star
Beiträge: 223


Delphi 2005 Architect
BeitragVerfasst: Mi 11.10.17 11:19 
Hallo Leute,
ich selbst habe noch Windows 7, meine Kollegen aber Windows 10.
Bisher liefen die Anwendungen auch alle schön auf Windows 10 bloß seit neuestem lassen sich die Anwendungen nichtmehr starten es kommt die Fehlermeldung im Anhang.
Ich würde mal davon ausgehen das es an irgendwelchen Windowsupdates hängt.
Vielleicht hat ja jemand eine Idee?


Moderiert von user profile iconNarses: Topic aus Sonstiges (Delphi) verschoben am Mi 11.10.2017 um 12:02
Einloggen, um Attachments anzusehen!
jaenicke
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starofftopic star
Beiträge: 18517
Erhaltene Danke: 1572

W10 x64 (Chrome, IE11)
Delphi 10.1 Ent, Oxygene, C# (VS 2015), JS/HTML, Java (NB), PHP, Lazarus
BeitragVerfasst: Mi 11.10.17 11:32 
Hier hat jemand dazu geraten die Systemdateien überprüfen zu lassen:
answers.microsoft.co...-ea64afb62bae?auth=1
Zumindest teilweise scheint das zu helfen.

_________________
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!
drstar
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starhalf ontopic star
Beiträge: 69

Windows 8.1/x64
Delphi 10.1
BeitragVerfasst: Gestern um 16:51 
Was unter Windows 10 auch helfen kann, ist ein echter Neustart (also auf Neustart klicken) - fährt man den Rechner herunter, wird er nur in den Ruhezustand versetzt. Der Benutzer wird zwar abgemeldet, das System läuft beim Wiederhochfahren jedoch in dem Zustand weiter, in dem es sich vor dem Herunterfahren befand (Schnellstart). Generell macht der Schnellstart gerne mal Probleme, mitunter lassen sich Updates tagelang nicht installieren, melden abstruse Fehlercodes, obwohl die eigentliche Ursache ein erforderlicher Neustart ist.

Sollte das nicht helfen, sollte zunächst das Dateisystem überprüft werden (chkdsk /x /f c: ) und, sollte der Fehler immer noch bestehen, die Integrität der Systemdateien überprüft werden (sfc /scannow), jeweils einzutippen über die Befehlszeile mit Administratorrechten.

Das ein Programm unter Windows 7 läuft, unter Windows 10 jedoch nicht, kommt eigentlich nur vor, wenn man sehr hardwarenah programmiert oder auf Schnittstellen zugreift, die für Treiber vorgesehen sind. Probleme kann es aber geben, wenn man auf Dienste zugreift, zumindest ab 1709 (Fall Creators Update), ich meine aber auch unter dem Creators Update (1703) läuft jeder Dienst bei ausreichend RAM in einem separaten svchost-Prozeß. Falls auf Dienste zugriffen wird, kann es hier zu Problemen kommen.