Autor Beitrag
klaansieck
Hält's aus hier
Beiträge: 2



BeitragVerfasst: Fr 15.09.17 21:34 
IdSMTP1.Username := 'xxx@xxx.lu';
IdSMTP1.Password := 'normal';
IdSMTP1.Host := 'mail.xxxu';
IdSMTP1.Port := 587;
IdSMTP1.UseTLS := utUseExplicitTLS;
IdSMTP1.Connect;
IdMessage1.From.Adress....
.. usw

try
....
IdSMTP1.Send(IdMessage1);

Ich bekomme die Meldung SSL.Bibliothek konnte nicht geladen werden.
Ich habe win32openssl-1_1_0e in das Ausführungsverzeichnis des clients gepackt.

Leider ohne Wirkung.
Was mach ich falsch?
mandras
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 399
Erhaltene Danke: 93

Win 7
D6 Prof, XE2 Prof
BeitragVerfasst: Fr 15.09.17 23:26 
Ich habs jetzt nicht in tiefer untersucht,
bei einem ähnlichen Programm habe ich verwendet:
ssleay32.dll

vielleicht hilfs...
Frühlingsrolle
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starhalf ontopic star
Beiträge: 2162
Erhaltene Danke: 399

[Win NT] 5.1 x86 6.1 x64
[Delphi] 7 PE, 2006, 10.1 Starter, Lazarus - [C#] VS Exp 2012 - [Android API 15] VS Com 2015, Eclipse, AIDE - [C++] Builder 10.1
BeitragVerfasst: Sa 16.09.17 01:57 
Wenn es nicht hilft, dann trage die betreffende Version nach, siehe hier. Und hier findest du die aktuelle 10.0.52 Indy Version, sofern du die bestehende Version aktualisiert möchtest.

_________________
„Politicians are put there to give you the idea that you have freedom of choice. You don’t. You have no choice. You have owners. They own you. They own everything." (George Denis Patrick Carlin)
klaansieck Threadstarter
Hält's aus hier
Beiträge: 2



BeitragVerfasst: Sa 16.09.17 08:58 
Ich hatte bereits die aktuellsten libeay32.dll/ssleay32.dll (32/64 bit) sowohl in das Ausführungsverzeichnis, sovie auch in system32/SysWOW64 kopiert.
So rät es embarcadero.com
Leider keine Änderung?