Autor Beitrag
galagher
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 2145
Erhaltene Danke: 42

Windows 7 64 Bit
Delphi XE2 Starter, Delphi 10.1 Starter
BeitragVerfasst: Do 07.09.17 22:35 
Hallo!

Nachdem das immer wieder vorkommt, poste ich das jetzt hier:

Delphi 10.1 Berlin stürzt sehr oft ab, und zwar vorwiegend dann, wenn es erst wenige Minuten läuft(!) und ich mit der Maus über Codeteile gehe, wobei die IDE da ja normalerweise Infos zum Code anzeigen sollte. Da man die Maus relativ oft über den Code bewegt, tritt das entsprechend häufig auf und ist natürlich besonders ärgerlich, wenn man Änderungen noch nicht gespeichert hat. Die sind dann weg.

Windows meldet dann:
Zitat:
Problemsignatur:
Problemereignisname: APPCRASH


Gibt's da ein Update/Bugfix?

_________________
gedunstig war's - und fahle wornen zerschellten karsig im gestrock. oh graus, es gloomt der jabberwock - und die graisligen gulpen nurmen!
jaenicke
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starofftopic star
Beiträge: 18506
Erhaltene Danke: 1570

W10 x64 (Chrome, IE11)
Delphi 10.1 Ent, Oxygene, C# (VS 2015), JS/HTML, Java (NB), PHP, Lazarus
BeitragVerfasst: Fr 08.09.17 08:29 
Dass Delphi 10.1 so abstürzt, dass es noch nicht einmal selbst den Fehler anzeigt, sprich mit Stacktrace usw., hatten wir hier noch nie. Und wir arbeiten täglich damit.

Sind die Treiber, insbesondere die Grafikkartentreiber, auf dem aktuellsten Stand? Denn es könnte ja bei der Anzeige des Hints ein Problem geben.
Hast du Addons wie CnPack usw. installiert?

Da du ohnehin nur die Starter hast: Hast du es einmal mit 10.2 Starter versucht?

_________________
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!
Frühlingsrolle
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starhalf ontopic star
Beiträge: 1648
Erhaltene Danke: 304

[Win NT] 5.1 x86 6.1 x64
[Delphi] 7 PE, 2006, 10.1 Starter, Lazarus - [C#] VS Exp 2012 - [Android API 15] VS Com 2015, Eclipse, AIDE - [C++] Builder 10.1
BeitragVerfasst: Fr 08.09.17 09:02 
Das könnte auch mit der JCL von Jedi zusammenhängen. Einfach mal testweise deaktivieren und schauen.

Kann man denn überhaupt die Delphi 10.1 Starter und 10.2 Starter am selben PC nutzen? Mein Lizenzschlüssel für die 10.2 Starter Version wird jedesmal abgelehnt. Ich vermute, das hängt mit der bestehenden 10.1 Starter Version zusammen.

_________________
„Wo andere blind der Wahrheit folgen, denk daran ... Nichts ist wahr!" (Assassin's Creed I-II)
galagher Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 2145
Erhaltene Danke: 42

Windows 7 64 Bit
Delphi XE2 Starter, Delphi 10.1 Starter
BeitragVerfasst: Fr 08.09.17 11:38 
user profile iconjaenicke hat folgendes geschrieben Zum zitierten Posting springen:
Sind die Treiber, insbesondere die Grafikkartentreiber, auf dem aktuellsten Stand? Denn es könnte ja bei der Anzeige des Hints ein Problem geben.
Die Grafiktreiber sind aktuell.

user profile iconjaenicke hat folgendes geschrieben Zum zitierten Posting springen:
Hast du Addons wie CnPack usw. installiert?
Nein.

user profile iconFrühlingsrolle hat folgendes geschrieben Zum zitierten Posting springen:
Das könnte auch mit der JCL von Jedi zusammenhängen. Einfach mal testweise deaktivieren und schauen.
Das trat auch auf, als die Jedi's noch nicht installiert waren!

_________________
gedunstig war's - und fahle wornen zerschellten karsig im gestrock. oh graus, es gloomt der jabberwock - und die graisligen gulpen nurmen!
jaenicke
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starofftopic star
Beiträge: 18506
Erhaltene Danke: 1570

W10 x64 (Chrome, IE11)
Delphi 10.1 Ent, Oxygene, C# (VS 2015), JS/HTML, Java (NB), PHP, Lazarus
BeitragVerfasst: Fr 08.09.17 12:12 
user profile iconFrühlingsrolle hat folgendes geschrieben Zum zitierten Posting springen:
Kann man denn überhaupt die Delphi 10.1 Starter und 10.2 Starter am selben PC nutzen? Mein Lizenzschlüssel für die 10.2 Starter Version wird jedesmal abgelehnt. Ich vermute, das hängt mit der bestehenden 10.1 Starter Version zusammen.
Das ist eigentlich kein Problem.

_________________
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!
Frühlingsrolle
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starhalf ontopic star
Beiträge: 1648
Erhaltene Danke: 304

[Win NT] 5.1 x86 6.1 x64
[Delphi] 7 PE, 2006, 10.1 Starter, Lazarus - [C#] VS Exp 2012 - [Android API 15] VS Com 2015, Eclipse, AIDE - [C++] Builder 10.1
BeitragVerfasst: Fr 08.09.17 12:12 
Zitat:
Delphi 10.1 Berlin stürzt sehr oft ab, und zwar vorwiegend dann, wenn es erst wenige Minuten läuft(!) und ich mit der Maus über Codeteile gehe[...]

Kommt das nachher auch vor, also nach den wenigen Minuten?

@jaenicke: Doch bei mir schon, leider. :D

_________________
„Wo andere blind der Wahrheit folgen, denk daran ... Nichts ist wahr!" (Assassin's Creed I-II)
galagher Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 2145
Erhaltene Danke: 42

Windows 7 64 Bit
Delphi XE2 Starter, Delphi 10.1 Starter
BeitragVerfasst: Fr 08.09.17 12:37 
user profile iconFrühlingsrolle hat folgendes geschrieben Zum zitierten Posting springen:
Kommt das nachher auch vor, also nach den wenigen Minuten?
Fast immer nur gleich nach dem Start von Delphi, so gut wie nie später, allerdings kam auch das schon vor.

Ich glaube, das liegt an den "noch nicht komplett geladenen Hint-Texten", ich weiss nicht, wie ich das besser ausdrücken soll! Wenn es nicht abstürzt, werden nämlich die Hints irgendwie "unfertig" angezeigt:
Einloggen, um Attachments anzusehen!
_________________
gedunstig war's - und fahle wornen zerschellten karsig im gestrock. oh graus, es gloomt der jabberwock - und die graisligen gulpen nurmen!