Autor Beitrag
bis11
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starhalf ontopic star
Beiträge: 1247
Erhaltene Danke: 2

Apple Mac OSX 10.11

BeitragVerfasst: Sa 16.05.09 16:15 
Hallo zusammen,

ich habe in einem kleinen Tutorial zusammengeschrieben, wie Ihr eurer Borland Developer Studio 2006 unter Windows 7 (64Bit) RC installieren könnt und es zum laufen bekommt. Es sind ein paar kleine Hindernisse zu überwinden, aber wie Ihr das macht zeigt euch dieses Tutorial.

Download - PDF ca. 400KB

Crosspost in der Delphi-Praxis.

Da dieses mein erstes Tutorial ist, welches ich hier Vorstelle, würde ich mich über ein bisschen Feedback freuen. :wink:
delphi-programmierer
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starhalf ontopic star
Beiträge: 48

DOS, WIN XP
RAD Studio 2010, Turbo Pascal 6.0
BeitragVerfasst: Fr 12.06.09 15:30 
Zitat:
Da dieses mein erstes Tutorial ist, welches ich hier Vorstelle, würde ich mich über ein bisschen Feedback freuen.


Das Tutorial ist recht gut, aber zwei Fragen hätte ich noch:
Wenn Du die Installation in der VirtualBox laufen lässt, bedeudet das doch, dass man die Anwendung nach der Installation auch nur daraus starten kann, oder?
Und welches Betriebssystem hast Du auf der virtuelle Maschine installiert? Win XP?

Ich hoffe Du kannst mir schnell antworten...


Gruß


Paul
bis11 Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starhalf ontopic star
Beiträge: 1247
Erhaltene Danke: 2

Apple Mac OSX 10.11

BeitragVerfasst: Fr 12.06.09 15:44 
user profile icondelphi-programmierer hat folgendes geschrieben Zum zitierten Posting springen:
Wenn Du die Installation in der VirtualBox laufen lässt, bedeudet das doch, dass man die Anwendung nach der Installation auch nur daraus starten kann, oder?
Ja, ich kann die Anwendung nur in der vrituellen Maschine starten.
user profile icondelphi-programmierer hat folgendes geschrieben Zum zitierten Posting springen:
Und welches Betriebssystem hast Du auf der virtuelle Maschine installiert? Win XP?
Ich habe Windows 7 RC (64Bit) in die Virtual Box installiert.
delphi-programmierer
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starhalf ontopic star
Beiträge: 48

DOS, WIN XP
RAD Studio 2010, Turbo Pascal 6.0
BeitragVerfasst: Fr 12.06.09 17:51 
jetzt wird alles klar... :idea:

Du hast Win 7 nicht als "primäres" Betriebssystem installiert, sondern in einer virtuelle Maschine auf dem bestehenden System.
Für diese Methode würde mein PC aber nicht genügen, da ich gerade so die Mindestanforderungen von Windows 7 erfülle. Deshalb läuft bei mir Windows 7 als "Boot-System".

Nun zu einem anderen Problem:
Ich habe Deinen Anweisungen bis jetzt gut Folgen können. Alle für das BDS nötigen Zusatzprogramme (.NET, ...) habe ich nach der gegebenen Reihenfolge installiert. Danach folgte der eigentliche Setup. Anschließend startete ich das BDS und es erschienen die selben Fehlermeldungen, wie Du beschrieben hast. Das Problem ist nur, dass ein weitere Fehler auftrat: "Falscher Parameter Code 87" Eine Liste gibt Aufschluss über Details. Darin stehen einige Packages (auch die vcl100.bpl und rtl100.bpl) mit angegebner Zeilennummer, wo der Fehler auftritt. Leider taucht der Fehler auch nicht nur einmal auf.

Hattest Du ähnliche Probleme oder weißt Du, wie man dieses lösen könnte? Die Recherche bei Google brachte kein Erfolg. :cry:

Ich hoffe Du hast einen Rat.

Viele Grüße

Paul
bis11 Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starhalf ontopic star
Beiträge: 1247
Erhaltene Danke: 2

Apple Mac OSX 10.11

BeitragVerfasst: Fr 12.06.09 18:15 
Hast Du auch die Updates eingespielt ?
delphi-programmierer
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starhalf ontopic star
Beiträge: 48

DOS, WIN XP
RAD Studio 2010, Turbo Pascal 6.0
BeitragVerfasst: Fr 12.06.09 19:34 
user profile iconbis11 hat folgendes geschrieben Zum zitierten Posting springen:
Hast Du auch die Updates eingespielt ?


Ja, alle vorgeschlagenen Ergänzugen wurden erfolgreich installiert.

Trotzdem die Fehlermeldung: "Systemfehler. Code: 87. Falscher Parameter."

Zitat:
+ $2[51F1A494]{rtl100.bpl } SysUtils.SysUtils.RaiseLastOSError (Line 16275, "sysutils.pas" + 7) + $2
+ $5[51F1A41D]{rtl100.bpl } SysUtils.SysUtils.RaiseLastOSError (Line 16262, "sysutils.pas" + 0) + $5
+ $2[51FFD5C9]{vcl100.bpl } StdCtrls.StdCtrls.TCustomListBox.CreateWnd (Line 4514, "StdCtrls.pas" + 3) + $2
+ $2[52053139]{vcl100.bpl } Forms.Forms.TCustomForm.FocusControl (Line 4287, "Forms.pas" + 2) + $2
+ $6[5203C998]{vcl100.bpl } Controls.Controls.TWinControl.WndProc (Line 7242, "Controls.pas" + 101) + $6
+ $5[520511CD]{vcl100.bpl } Forms.Forms.TCustomForm.WndProc (Line 3284, "Forms.pas" + 125) + $5
+ $6[5203C150]{vcl100.bpl } Controls.Controls.TWinControl.MainWndProc (Line 7021, "Controls.pas" + 3) + $6
+ $0[51F40BB0]{rtl100.bpl } Classes.Classes.StdWndProc (Line 11572, "classes.pas" + 8) + $0
+ $1F7[778DC6BF]{USER32.dll } gapfnScSendMessage + $1F7
+ $2CD[778DC795]{USER32.dll } gapfnScSendMessage + $2CD
+ $138[778D5027]{USER32.dll } IsDialogMessageW + $138
+ $197[778D5086]{USER32.dll } IsDialogMessageW + $197
+ $2B[77C1817B]{ntdll.dll } KiUserCallbackDispatcher + $2B
+ $4[5203BBB4]{vcl100.bpl } Controls.Controls.TWinControl.DestroyWnd (Line 6835, "Controls.pas" + 11) + $4
+ $F[5203BDF5]{vcl100.bpl } Controls.Controls.TWinControl.DestroyHandle (Line 6920, "Controls.pas" + 5) + $F
+ $5[5203BE82]{vcl100.bpl } Controls.Controls.TWinControl.CMRecreateWnd (Line 6940, "Controls.pas" + 4) + $5
+ $6[520389E7]{vcl100.bpl } Controls.Controls.TControl.WndProc (Line 5143, "Controls.pas" + 83) + $6
+ $6[5203C998]{vcl100.bpl } Controls.Controls.TWinControl.WndProc (Line 7242, "Controls.pas" + 101) + $6
+ $5[520511CD]{vcl100.bpl } Forms.Forms.TCustomForm.WndProc (Line 3284, "Forms.pas" + 125) + $5
+ $C[52038674]{vcl100.bpl } Controls.Controls.TControl.Perform (Line 5018, "Controls.pas" + 5) + $C
+ $12[5203BE46]{vcl100.bpl } Controls.Controls.TWinControl.RecreateWnd (Line 6930, "Controls.pas" + 0) + $12
+ $6[5200E21B]{vcl100.bpl } ExtCtrls.ExtCtrls.TCustomPanel.CMDockClient (Line 2495, "ExtCtrls.pas" + 26) + $6
+ $6[520389E7]{vcl100.bpl } Controls.Controls.TControl.WndProc (Line 5143, "Controls.pas" + 83) + $6
+ $6[5203C998]{vcl100.bpl } Controls.Controls.TWinControl.WndProc (Line 7242, "Controls.pas" + 101) + $6
+ $5[52044162]{vcl100.bpl } Controls.Controls.TDockTree.WndProc (Line 11705, "Controls.pas" + 55) + $5
+ $15[5203DAED]{vcl100.bpl } Controls.Controls.TWinControl.DockDrop (Line 7798, "Controls.pas" + 1) + $15
+ $D[20EE679B]{designide100.bpl} IDEDockPanel.IDEDockPanel.TEditorDockPanel.DockDrop (Line 174, "IDEDockPanel.pas" + 17) + $D
+ $10[52038251]{vcl100.bpl } Controls.Controls.TControl.ManualDock (Line 4869, "Controls.pas" + 38) + $10
+ $D[5204199E]{vcl100.bpl } Controls.Controls.TDockZone.SetControlName (Line 10247, "Controls.pas" + 10) + $D
+ $5[520429A8]{vcl100.bpl } Controls.Controls.TDockTree.LoadFromStream (Line 10906, "Controls.pas" + 59) + $5
+ $E[20EED4B8]{designide100.bpl} DeskForm.DeskForm.TDesktopForm.LoadDockStream (Line 611, "DeskForm.pas" + 38) + $E
+ $F[20EE6B2D]{designide100.bpl} IDEDockPanel.IDEDockPanel.TEditorDockPanel.LoadState (Line 267, "IDEDockPanel.pas" + 21) + $F
+ $18[20BF318B]{coreide100.bpl} EditorForm.EditorForm.TEditWindow.LoadDockData (Line 2447, "EditorForm.pas" + 3) + $18
+ $F[20EE6B2D]{designide100.bpl} IDEDockPanel.IDEDockPanel.TEditorDockPanel.LoadState (Line 267, "IDEDockPanel.pas" + 21) + $F
+ $449E[0041B1E6]{bds.exe } bds.bds.Finalization + $449E
+ $3[20BBD3E6]{coreide100.bpl} Desktop.Desktop.TDesktopState.Load (Line 1502, "Desktop.pas" + 5) + $3
+ $6[20BBCE4F]{coreide100.bpl} Desktop.Desktop.TDesktopStates.LoadDesktop (Line 1361, "Desktop.pas" + 4) + $6
+ $7[20BBB8A1]{coreide100.bpl} Desktop.Desktop.LoadDefaultDesktopState (Line 939, "Desktop.pas" + 21) + $7
+ $0[20BBC158]{coreide100.bpl} Desktop.Desktop.LoadDesktop (Line 1056, "Desktop.pas" + 75) + $0
+ $40[00411375]{bds.exe } AppMain.AppMain.ProcessFromProject (Line 4485, "ui\AppMain.pas" + 13) + $40
+ $6[520389E7]{vcl100.bpl } Controls.Controls.TControl.WndProc (Line 5143, "Controls.pas" + 83) + $6
+ $6[5203C998]{vcl100.bpl } Controls.Controls.TWinControl.WndProc (Line 7242, "Controls.pas" + 101) + $6
+ $5[520511CD]{vcl100.bpl } Forms.Forms.TCustomForm.WndProc (Line 3284, "Forms.pas" + 125) + $5
+ $6[5203C150]{vcl100.bpl } Controls.Controls.TWinControl.MainWndProc (Line 7021, "Controls.pas" + 3) + $6
+ $0[51F40BB0]{rtl100.bpl } Classes.Classes.StdWndProc (Line 11572, "classes.pas" + 8) + $0
+ $1F7[778DC6BF]{USER32.dll } gapfnScSendMessage + $1F7
+ $2CD[778DC795]{USER32.dll } gapfnScSendMessage + $2CD
+ $8FC[778DCDC4]{USER32.dll } gapfnScSendMessage + $8FC
+ $A[778D1B16]{USER32.dll } DispatchMessageA + $A


--> Smilies einfach ignorieren

Gruß

Paul

Moderiert von user profile iconNarses: Smilie-Parsing für dieses Posting deaktiviert
Rasmus
Hält's aus hier
Beiträge: 3



BeitragVerfasst: So 09.08.09 00:36 
Hallo,

Danke für das Tutorial. Bei der Installation hatte ich Probleme, das Service Pack 1 zum .NET Framework 1.1 zu installieren. Sie wurde immer mit einer Fehlermeldung beendet. Nachdem ich eine integrierte Installation mit Service Pack erstellt hatte, konnte ich das Framework komplett installieren. Anschließend ließ sich BDS 2006 ohne weiter Probleme installieren.

Bei der anschließenden Installation des BDS Updates 2 erscheint nun aber eine Fehlermeldung, dass es sich hierbei um die Enterprise Version handelt und diese nicht zur installierten Version passt. Ich habe aber die Enterprise Version installiert. Die im Tutorial angegebenen Pfade habe ich natürlich angepasst.

Leider komme ich an dieser Stelle nicht weiter. Hat vielleicht jemand ähnliche Probleme gehabt oder eine Idee, wie sich das Update installieren lässt?

Viele Grüße
bis11 Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starhalf ontopic star
Beiträge: 1247
Erhaltene Danke: 2

Apple Mac OSX 10.11

BeitragVerfasst: So 09.08.09 09:18 
Hallo Rasmus,

kann es sein, dass Du das falsche Update 2 für die BDS ausführst ?
Rasmus
Hält's aus hier
Beiträge: 3



BeitragVerfasst: So 09.08.09 20:28 
Hallo Rolf,

Nein, das hatte ich ja versucht auszudrücken. Ich besitze die Enterprise Version und versuche das zugehörige Update 2 zu installieren welches sich auf CD4 befindet.
Den Pfad habe ich wie folgt angepasst:
D:\borland\update2\de\ent\bds2006_de_ent_upd2.msp

Es ist aber egal, welches Update ich versuche zu installieren. Es kommt immer die Meldung, das es die falsche Version ist.

Gruß
Rasmus
bis11 Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starhalf ontopic star
Beiträge: 1247
Erhaltene Danke: 2

Apple Mac OSX 10.11

BeitragVerfasst: Mo 10.08.09 17:20 
user profile iconRasmus hat folgendes geschrieben Zum zitierten Posting springen:
Es ist aber egal, welches Update ich versuche zu installieren. Es kommt immer die Meldung, das es die falsche Version ist.

Achso, entschuldige das hatte ich falsch verstanden. Hast Du denn schon mal den Download von CodeGear probiert ? Dort kannst Du Dir doch auch das Update 2 runterladen. Vielleicht hat ja auch das Setup von der CD einen Schuss.

Desweiteren kannst Du es ja auch noch probieren, wenn Du die Setupdatei lokal auf Deine Festplatte kopierst und von da ausführst.
Rasmus
Hält's aus hier
Beiträge: 3



BeitragVerfasst: Di 11.08.09 08:58 
Hallo,

Ich habe beide Möglichkeiten ausprobiert. Sie endeten jeweils mit dem beschriebenen Fehler.
Ich habe die Fehlermeldung mal als Bild angehängt.

Gruß
Rasmus
Einloggen, um Attachments anzusehen!
Ares
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starontopic star
Beiträge: 128



BeitragVerfasst: Mo 17.08.09 11:14 
Hallo Rasmus,

ich hatte genau die gleichen Probleme. Bei der Installation einfach die UAC ausschalten, dann tritt der Fehler nicht mehr auf.
jaenicke
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starofftopic star
Beiträge: 18718
Erhaltene Danke: 1624

W10 x64 (Chrome, IE11)
Delphi 10.2 Ent, Oxygene, C# (VS 2015), JS/HTML, Java (NB), PHP, Lazarus
BeitragVerfasst: Do 20.08.09 11:01 
Die mit der Abschaltung der UAC verbundenen Sicherheitsprobleme machen die Lösung aber im produktiven Einsatz und außerhalb einer virtuellen Maschine untauglich.