Autor Beitrag
Kasko
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starontopic star
Beiträge: 60



BeitragVerfasst: So 09.09.18 22:26 
Hallo zusammen,

Ich habe Visual Studio lange Zeit nur für C#.net verwendet. Da ich alle dafür notwendigen Workloads bereits von Anfang an installiert hatte, hab ich den VS17 Installer lange Zeit nicht angefasst. Als ich nun aber einen weiteren Workload installieren wollte, kam die Meldung, dass ich den Installer aktualisieren müsse, was irgendwie logisch ist, das ich ihn wie gesagt lange Zeit nicht angerührt habe. Allerdings landete ich in der, mittlerweile im Netz sehr populären, Endlosschleife. Da keiner dieser "Tipps" aus diversen Foren geholfen hat, oder gar nicht erst ausprobiert wurde, weil man schon durch kurzes Nachdenken mitbekommen musste, dass diese Tipps zum scheitern verurteilt waren, habe ich kurzerhand einfach den wahrscheinlich aktuellsten Installer aus dem Internet gezogen und installiert. Da der Installer ja bereits auf dem PC installiert war, konnte ich so einfach den Installer aktualisieren. Allerdings wurden alle Workloads zurückgesetzt, was zur Folge hatte, dass ich sie neu installieren musste.

Bei .Net-Desktopentwicklung ging alles gut. Allerdings trat sowohl bei Entwicklung für die universelle Windows-Plattform als auch bei Desktopentwicklung mit C++ ein Fehler auf. Win10SDK_10.0.17134 konnte nicht installiert werden. Nach endlosem Suchen nach Lösungen musste ich das Windows Software Dev Kit separat installieren, dann traten keine Fehler mehr beim Installieren der Workloads auf.

Endresultat: Wenn ich versuche VS normal oder als Admin zu starten kommt die Meldung, dass die Installation nicht abgeschlossen ist und ich den Installer öffnen soll. Dort steht aber nichts davon. Wenn ich hier versuche VS zu starten kommt die Meldung Fehler beim Setupvorgang (Anbei das Protokol). Ich habe gefühlt 100mal die Workloads neu installiert und ein "Reparation" durchgeführt aber... Nichts.

Bitte um Mithilfe.
LG Kasko ;)
Einloggen, um Attachments anzusehen!
Th69
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starontopic star
Moderator
Beiträge: 3884
Erhaltene Danke: 789

Win7
C++, C# (VS 2015/17)
BeitragVerfasst: Mo 10.09.18 11:03 
Hallo,

ich habe gerade mal bei mir erfolgreich den VS Installer aktualisiert sowie das neueste Update für VS (15.8.3) installiert (also keine "Endlosschleife").

Ich nehme an, der Fehler tritt bei dir deswegen auf, weil das Setup-Programm (intern) noch die fehlerhafte Installation vom Win10SDK registriert hat, welche durch dein manuelles Installieren aber nicht erkannt wurde.

Ich denke da hilft nur (wenn "Reparieren" also nicht geholfen hat):
- VS deinstallieren
- Neustart
- VS neu installieren
Sinspin
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starofftopic star
Beiträge: 1124
Erhaltene Danke: 73

Win7
DXE2 Prof, Lazarus
BeitragVerfasst: Mo 10.09.18 11:06 
Hallo,

hast Du in der Ereignisanzeige, für Installer Ereignisse, mal geschaut ob da mehr Informationen zu dem Fehler stehen?

Hast Du es mit einer vollständigen Neuinstallation versucht?

Vlt irre ich mich, aber im Log steht auch was von "VisualStudio.15.Release". Du verwendest den VS17 Installer.
Hast Du noch nen 15ner drauf?

Kennst Du das developercommunity.v...ktioniert-nicht.html?

_________________
Solange keine Zeile Code geschrieben ist, läuft ein Programm immer fehlerfrei.
Ich teste nicht, weil ich Angst habe Fehler zu finden.
Ralf Jansen
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starhalf ontopic star
Beiträge: 4337
Erhaltene Danke: 873


VS2010 Pro, VS2012 Pro, VS2013 Pro, VS2015 Pro, Delphi 7 Pro
BeitragVerfasst: Mo 10.09.18 11:45 
Visual Studio 2017 = Visual Studio 15

Nicht verwirren lassen ;)

Für diesen Beitrag haben gedankt: Sinspin
Kasko Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starontopic star
Beiträge: 60



BeitragVerfasst: Mo 10.09.18 22:04 
Ich habe jetzt den ganzen Tag über neu installiert und repariert aber nichts klappt. Könnte es was mit einer Inkompatibilität der WinSDK-Versionen zu tun haben? Der Installer will ja die Version 10.0.17134.0 bzw. 10.0.17134.1 installieren und das klappt nicht. Im Internet ist diese Version auch nicht zu finden. Die beiden aktuellsten Versionen sind 10.0.17134.12 und 10.0.16299.91. Durch separates Installieren hab ich die Version 10.0.17134.12 installiert.

Die Fehlermeldung lautet ja auch: Nicht unterstützte Schnittstelle
Kasko Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starontopic star
Beiträge: 60



BeitragVerfasst: Di 11.09.18 14:25 
Okay nach nächtelangem Suchen kann ich sagen, dass der Fehler nicht bei den WinSDK-Versionen liegt. Der Fehler tritt bereits bei der alleinigen Installation der Visual Studio IDE ohne Workloads auf. Die Fehlermeldung lautet: SetupEngine.Installer.LaunchProduct reported error. [Win32Exception: Schnittstelle nicht unterstützt at Win32Exception: Schnittstelle nicht unterstützt]

Das Auftreten dieses Fehlers sorgt wahrscheinlich dann für einen Fehler bei der SDK Installation. Deshalb funktioniert auch eine separate Installation.
Kasko Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starontopic star
Beiträge: 60



BeitragVerfasst: Fr 14.09.18 00:21 
Sonst hat keiner eine Idee?
Th69
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starontopic star
Moderator
Beiträge: 3884
Erhaltene Danke: 789

Win7
C++, C# (VS 2015/17)
BeitragVerfasst: Fr 14.09.18 07:29 
Sorry, leider nein.
Am besten, du wendest dich direkt an Visual Studio Developer Community.