Autor Beitrag
Gagamba
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starontopic star
Beiträge: 46



BeitragVerfasst: Fr 25.01.19 19:39 
Hallo,
ich habe bisher immer die Hilfe mit dem Aufruf Application.HelpCommand aufgerufen, vorher ist Application.Helpfile auf den entsprechenden Dateibezeichner gesetzt worden. Unter neueren Windows-Systemen scheint aber dieser Aufruf die Windows-Online-Hilfe aufzurufen?! Was muss ich einstellen, damit das wieder funktioniert? Unter XP lief das einwandfrei durch...
Danke: Siegfried
PS ich benutze Delphi7
jaenicke
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starofftopic star
Beiträge: 18686
Erhaltene Danke: 1619

W10 x64 (Chrome, IE11)
Delphi 10.2 Ent, Oxygene, C# (VS 2015), JS/HTML, Java (NB), PHP, Lazarus
BeitragVerfasst: Fr 25.01.19 20:02 
Es gibt die aktuelle Version als Community Edition auch kostenlos, wer kein bzw. nur wenig Geld mit seinen Programmen verdient, muss also nicht bei einer so alten Version bleiben.

Wie man die uralten .hlp Dateien noch weiter benutzen kann, habe ich hier beschrieben:
www.entwickler-ecke.....php?p=697956#697956
Für eigene Programme sollte man es damit aber gar nicht mehr erst versuchen. Es gibt auch Units um stattdessen eine .chm Hilfedatei einzubinden, die ohnehin viel mehr Möglichkeiten bietet.

_________________
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!
GuaAck
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starofftopic star
Beiträge: 298
Erhaltene Danke: 28

Windows 8.1
Delphi 7 Pers.
BeitragVerfasst: Mo 28.01.19 23:39 
Hallo,

es scheint von Microsoft zwei Lösungen dazu zu geben. Ich sehe in meiner Systemsteuerung, dass ich Helpviewer (2015) installiert habe. Damit funktioniert es bei mir bestens. F1 geht (kontextsensitiv). Ich hatte nur ein Problem: Zu Hause bestens, im Büro (auch Windows 8.1, Delphi 7) hatte ich nach der Installation keinen Zugriff mehr auf den Netzwerkdrucker. Helpviewer wieder deinstalliert, Drucker ging wieder. Zu Hause habe ich auch einen Netzwerkdrucker, also wohl kein allgemeines Problem, anmerken wollte ich es aber doch.

Die Community Edition Lizenz scheint auf 1 Jahr begrenzt zu sein, so wird es jedenfalls beim Start angezeigt.

Gruß
GuaAck
haentschman
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starhalf ontopic star
Beiträge: 285
Erhaltene Danke: 33


DX10 Berlin Professional
BeitragVerfasst: Di 29.01.19 07:09 
Moin... :wink:
Zitat:
Die Community Edition Lizenz scheint auf 1 Jahr begrenzt zu sein, so wird es jedenfalls beim Start angezeigt.

...dann holst du dir wieder (kostenlos) einen neuen Key für deine bestehende Installation. :P
jaenicke
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starofftopic star
Beiträge: 18686
Erhaltene Danke: 1619

W10 x64 (Chrome, IE11)
Delphi 10.2 Ent, Oxygene, C# (VS 2015), JS/HTML, Java (NB), PHP, Lazarus
BeitragVerfasst: Di 29.01.19 18:57 
Beziehungsweise die dann aktuelle Version. Angekündigt ist jedenfalls, dass es die Community Edition dauerhaft kostenlos geben soll.

Embarcadero hat angesichts der Konkurrenz an der Stelle auch kaum eine andere Wahl...

_________________
Alle eigenen Projekte sind eingestellt, ebenso meine Homepage, Downloadlinks usw. im Forum bleiben aktiv!