Autor Beitrag
Csharp-programmierer
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starontopic star
Beiträge: 696
Erhaltene Danke: 10

Windows 8.1
C# (VS 2013)
BeitragVerfasst: So 10.07.16 01:01 
Hallo,
ich habe eine Klassenbibliothek erstellt, in der ich mir das Metroframework installiert habe. Die einzelnen Controls kann ich mir manuell schon basteln, aber wenn ich versuche, die DLL in den Werkzeugkasten zu implimentieren, werden angeblich keine Steuerelemente gefunden, die man in den Werkzeugkasten packen kann.
Dann habe ich eine neue WindowsFormsAnwendung angelegt, da das Framework installiert, dieses in den Werkzeugkasten gelegt und da funktioniert es. Geht es nur bei einer DLL nicht?

_________________
"Wer keinen Sinn im Leben sieht, ist nicht nur unglücklich, sondern kaum lebensfähig" - Albert Einstein
Th69
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starontopic star
Moderator
Beiträge: 3412
Erhaltene Danke: 643

Win7
C++, C# (VS 2010/12/13/15)
BeitragVerfasst: So 10.07.16 10:31 
Wenn du die DLL in den Werkzeugkasten (ToolBox) installierst, liegen denn im selben Verzeichnis dann auch die Metro-Framework DLLs (denn NuGet packt diese ja ersteinmal nur in das Verzeichnis 'packages' und erst beim Kompilieren der Gesamtanwendung werden diese herangezogen)?

Ich bin mir nicht sicher, ob du evtl. für die ToolBox (auch) MetroFramework (Design) benötigst?!
Csharp-programmierer Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starontopic star
Beiträge: 696
Erhaltene Danke: 10

Windows 8.1
C# (VS 2013)
BeitragVerfasst: So 10.07.16 11:03 
Also ich habe jetzt mal in dem Debug Verzeichnis geschaut und da liegen die anderen DLL's. Aber in den Werkzeugkasten kann ich nach wie vor keine Elemente hinzufügen
Einloggen, um Attachments anzusehen!
_________________
"Wer keinen Sinn im Leben sieht, ist nicht nur unglücklich, sondern kaum lebensfähig" - Albert Einstein
Th69
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starontopic star
Moderator
Beiträge: 3412
Erhaltene Danke: 643

Win7
C++, C# (VS 2010/12/13/15)
BeitragVerfasst: So 10.07.16 11:12 
Probiere dann mal auch die MetroFramework.Design.dll dort reinzukopieren.
Csharp-programmierer Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starontopic star
Beiträge: 696
Erhaltene Danke: 10

Windows 8.1
C# (VS 2013)
BeitragVerfasst: So 10.07.16 13:50 
Ja, ich habe nun die MetroFramework.Design.dll in den Debug Ordner kopiert (manuell) und der Werkzeugkasten nimmt die Elemente immer noch nicht an

_________________
"Wer keinen Sinn im Leben sieht, ist nicht nur unglücklich, sondern kaum lebensfähig" - Albert Einstein
Th69
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starontopic star
Moderator
Beiträge: 3412
Erhaltene Danke: 643

Win7
C++, C# (VS 2010/12/13/15)
BeitragVerfasst: So 10.07.16 14:36 
Vllt. mußt du diese auch explizit von deinem DLL-Projekt aus referenzieren (schau mal ob diese beim Referenzieren des NuGet-Paketes schon automatisch gemacht wurde - aber wahrscheinlich nicht, denn sonst würden diese ja im Ausgabeverzeichnis hinkopiert worden sein), aber mehr fällt mir ersteinmal auch nicht ein.